TroubleShooting

Please also  check the FAQ pages.
 

Error Messages

  • 'ERROR: ( )/_ISO/MAINMENU/some.iso IS NOT CONTIGUOUS!' - Either the ISO is not contiguous (fix it by running \MAKE_THIS_DRIVE_CONTIGUOUS.cmd or use RMPrepUSB - Ctrl+F2) or else there is some problem with the ISO file (check it is not corrupted).
  • 'Warning! No such command : xxxx :' You are using an old version of grub4dos - update the grldr file to at least a 2014 version. Use the one in the latest E2B download.
  • An error is displayed which contains a partial filename but not the full complete path or filename, some similar files work but others don't - Avoid using 'odd' characters for folder and file names - stick to A-Z, 0-9 and _ and -  (do not use characters such as ( or ) or & or ! or " or '). Keep filenames short (less than 16 characters if possible).
  • .imgPTN will not boot in MBR\CSM mode on some systems (flashing cursor) - Rename the .imgPTN file to .imgPTN23A.
  • Checking last sector is accessible (pauses for several minutes) - this is a manifestation of a bug with grub4dos (currently under investigation) and some BIOSes and usually happens only with NTFS disks. It is usually caused by one 'odd' file on the drive. Try re-making the USB drive  with RMPrepUSB v2.1.710 or later (or use the E2B Make_E2B_USB_DRIVE script) and the problem will probably disappear. This issue often occurs with the 'looking for /WINHELPER.USB' error below. You can skip the test by using set CHECKBIOS= in your \_ISO\MyE2B.cfg file.
  • 'Looking for /WINHELPER.USB...' (then stops) - If the loading of the main menu stops here, check the \AutoUnattend.xml and \Unattend.xml on the Easy2Boot drive and the Auxilliary 'Helper' USB Flash drive (if used) are OK. This seems to happen when the files have been freshly copied and often does not happen a second time. The cause is unknown. If you see this error please report any diagnostic messages\numbers to me to help to diagnose the problem (or you can look in menu.lst yourself to see what commands were used after each dot was printed). Repartition using RMPrepUSB v2.1.710 or later, If you never use a 'Helper' USB flash drive, make a \_ISO\MyE2B.cfg file and set the NOHELPER option.
  • XP hangs when white text-mode loading bar completes - This may be due to the formatting + 'queer' BIOS or the size of the USB stick being reported incorrectly - re-partition using RMPrepUSB v2.1.710+ to see if the problem goes away.
  • Not all my .xml or .key files are listed in the menu - some are missing! There is a limit to the number of files that can be detected due to memory limitations. Delete all the .key, .txt and .xml files that you don't need in the \_ISO\Windows folders. If you have lots of .key files, put all your keys in the CHOOSE FROM A LIST.key file and delete the other .key files.
  • 'Error 60 - File not contiguous' - Most ISO files need to be contiguous for E2B to work - Use RMPrepUSB Ctrl+F2 to defrag files on the whole drive using WinContig. If you have an NTFS drive - also see here. You can try renaming the iso as .isomem but it may not be successful! if you have a small (<32GB) drive, FAT32 is often better for defragging files (but you cannot have files >4GB on FAT32). You can rename the file extension to .isomem - but it may not work unless it is a .iso and contiguous.
    If you still have problems, try Auslogics disk defrag or Defraggler to view the cluster usage on the disk and defrag it. See here for more details.
  • 'Error 15: File not found' - If you see this when you select a menu item and press Enter, you probably are using FASTLOAD and have changed the drive contents without refreshing the menu cache file. Choose the last menu item in the Main menu 'REFRESH THIS FASTLOAD CACHE MENU' to re-enumerate the files on the Easy2Boot drive to make an up-to-date copy of the menu. If you have not enabled FASTLOAD, then check that the filenames and paths specified in the .mnu file you are using are all correct.
  • 'Error 16: Inconsistent filesystem structure '- this is usually a symptom that grub4dos cannot write to the USB drive - this may be because you are trying to run grub4dos under a VM or via Plop! which is a read-only USB driver. Use a real system and make sure the USB drive is not write-protected or use the free Oracle Virtual Box + DavidB's VMUB utility. If testing using VMWare+Plop! then when the E2B menu loads, select the UTILITIES menu and then the Load grub4dos fast USB 2.0 driver menu option - this loads grub4dos's own USB driver which is rd/wr - you can then try any of the E2B payloads.
  • Bad or Invalid E:\Unattend.xml or similar - or 'Windows Setup encountered an internal error while loading or searching for an unattend answer file' - check that the blank \AutoUnattend.xml and \Unattend.xml are at least as large as your original .xml file - if not you will need to make them larger! Check that no other drive contains these xml files in the root.
  • 'Wiping /AutoUnattend.xml and /Unattend.xml files... '- If the E2B boot process seems to pause here for a long time or hang, check your USB drive (and USB Flash auxilliary drive if also connected) for filesystem integrity errors. If necessary repartition the drive and ensure that the two xml files in the root of the drive are copied onto the USB drive first, before the large payload files.
  • Tip: Always test booting on a real system if it fails to boot under QEMU or a VM! QEMU is most likely to fail, Oracle VM Manager Virtual Box is least likely to fail (depending on settings) - a boot on real system is the acid test! If testing under an emulator - use Virtual Box with DavidB's 'Virtual Machine USB Boot' application which allows full rd/wr access by the VM.
  • You demo'd an XP based ISO booting in Oracle Virtual Box but I can't get it to work! - Try turning the Settings - System - Acceleration features OFF (or ON if they are already off!) and set OS to XP. Enabling VTx will give faster performance.
  • Blue Screen of Death - Error 0x0000007B - if you are trying to boot an XP-based non-install ISO (e.g. BartPE, ERDCommander, etc.) try .isomemf01 or .isomemwinv. Look for a .mnu file for your iso  in the docs folder.
  • Linux not fully booting - First - test on a real system! Try pressing the ESC key to see the text messages - this may give a clue as to the problem! Ctrl+S may stop the text from scrolling so you can read it and Ctrl-Q may resume scrolling.
  • Some linux ISOs just won't boot! - check the (small) list of known 'bad' ones here. Search for a tutorial on this site for a workaround.
  • Not all ISOs, etc, work under Oracle Virtual Box - check the Settings - System - Acceleration setting and try enabling or disabling VT/AMD-V  (XP may need VT disabled). Also check 64-bit is enabled or disabled (depending on OS) in the General - Basic OS settings.
  • 'WARNING: PTN TABLE 3 IS ALREADY IN USE!' - You are using a .mnu file that requires the 3rd and 4th partition entries in the USB boot drive to be unused. Easy2Boot uses  these two entries and so will refuse to run as it would destroy your 3rd partition. If you don't need the 3rd Primary partition then use a partition manager to delete it (or re-partition the drive to have two Primary partitions or just one Primary partition and any number of Logical partitions). Otherwise you cannot use this particular Easy2Boot .mnu file.
  • 'WARNING: PTN TABLE 4 IS ALREADY IN USE!' - Easy2Boot needs the last (4th) primary partition entry to be empty in order to boot linux ISOs. Delete the 4th Primary partition (you will be prompted to do this) or re-partition the USB drive so that you have two Primary partitions or just one Primary partition and any number of Logical partitions.
  • Enter the product key to activate Windows (Windows 8) - The product key was incorrect. Check that it matches the ISO you are using for installation.
  • 'A required CD/DVD drive device driver is missing.'

If installing from a USB Hard disk or 'fixed-disk' type of USB Flash drive - see here.
If you got the Blue console windows and the Repair question but still have this problem, it can be due to a 
corrupted ISO (even though it looks OK and the \Sources\Install.wim can be seen and it was mounted by ImDisk OK!) - check the MD5 hash value of the file on the USB drive against it's correct value.
 If you are trying to install Windows Vista or later OS's from an ISO, make sure that you use the first partition on a USB flash drive to hold the Easy2Boot files and ISOs. For Vista and later OS's you should always see a blue console window appear (see Windows video) before the Setup GUI starts. Windows Vista and later OS's will detect an AutoUnattend.xml file on the first partition of a removable drive (e.g. Flash drive but not on a hard disk). The AutoUnattend.xml file will cause a Blue Console window (LoadISO.cmd file) to run which will load the Windows install ISO file as a RAM drive - Windows Setup will then be able to find the \Sources\Install.wim file from inside the RAM drive and so will not think that a driver is required so that it can access the 'DVD'.

If you are using an E2B 'fixed-disk' type of USB drive, try converting the Windows Install ISO to a partition image (.imgPTN file) using MakePartImage - then you won't need an extra USB Helper flash drive.

  • 'Cannot install required files' - During the 'Copy/Expanding Windows Files' stage of Vista/7/8/etc. somewhere between 1% and 99% (usually at same xx% place every time) the installation cancels itself. The iso file may be corrupt - check the MD5 checksum of the iso file is correct (Google it). Error-check the drive, delete the iso file and re-copy it to the USB drive. Ensure it is contiguous using WinContig (RMPrepUSB - Ctrl+F2) before booting with Easy2Boot.
  • The sub-menus (such as Backup, Dos, Utilities, etc) do not appear in my GFX Boot menu (old versions of E2B only) - If you have added a GFXBoot Menu, you need to copy the GFXSubMenu files from \_ISO\docs\GFXSubMenu Files to \_ISO\MAINMENU. You can delete the ZZSubMenuxxx.mnu files that are already in the MAINMENU folder as these are only used for non-GFXBoot Menu configurations.
  • Why isn't E2B installing XP to my AHCI system (I don't get a DPMS2 menu)? - You need  to add the DriverPacks Mass Storage driver files - see here for details.
  • Need more space:4kb, drive space available 0 kb - FAT error:due to prohibited access or directory full - This is due to the virtual floppy F6 disk not having enough room - instead of the DPMS Option default of 2 (SATA+Firadisk+WinVBlock), try option 1 (SATA+Firadisk) instead.

 

Search